Get in touch
Back
Maintenance

Upgrading database

Completed 7 May at 12:12pm CEST.

QuickMail Application
Completed

Posted 7 May at 12:12pm CEST.
Started

We are currently upgrading our database, we expect a small interruption of service of 15 minutes when we'll switch the databases to make sure it's done safely.

Posted 7 May at 12:00pm CEST.