Get in touch
Back
Resolved

Database outage

Started .

QuickMail Application
Created

We had an outage with our database, we resolved it for now and will monitor it for the next 12 hours. Everything should be up and running again.

Posted .